Thanks for visiting the site !!! Visit below intrested Ads to support us if you like the site .Sharing is caring .keep distance and keep safe . Happy Learning ... 😀

WebSphere Server startup failed with Hung thread in logs

WebSphere App Node failed to start with below error . As the Application use Datasource and due to some DataSource connectivity issue with back groups it failed to connect during Application startup and make a thread hung and finally unable to bring up websphere successfully . form the logs base on the thread that shous hung we should abel to conlude issue is due to DB

com.ibm.ws.rsadapter.jdbc.WSJdbcConnection.setReadOnly

ERROR from SystemOut.log shown below .

D:\AppSrv0`logs\ffdc\server1_5f52b091_21.03.23_19.47.49.8791352299901658462190.txt com.ibm.ws.rsadapter.jdbc.WSJdbcConnection.setReadOnly 2016

[3/23/21 19:53:42:619 SGT] 000000c9 ThreadMonitor W WSVR0605W: Thread “server.startup : 0” (00000053) has been active for 714433 milliseconds and may be hung. There is/are 1 thread(s) in total in the server that may be hung.

at com.ibm.ws.webcontainer.component.WebContainerImpl.install(WebContainerImpl.java:380)

at com.ibm.ws.webcontainer.component.WebContainerImpl.start(WebContainerImpl.java:719)

at com.ibm.ws.runtime.component.ApplicationMgrImpl.start(ApplicationMgrImpl.java:1249)

at com.ibm.ws.runtime.component.DeployedApplicationImpl.fireDeployedObjectStart(DeployedApplicationImpl.java:1591)

at com.ibm.ws.runtime.component.DeployedModuleImpl.start(DeployedModuleImpl.java:708)

at com.ibm.ws.runtime.component.DeployedApplicationImpl.start(DeployedApplicationImpl.java:1162)

at com.ibm.ws.runtime.component.ApplicationMgrImpl.startApplication(ApplicationMgrImpl.java:801)

at com.ibm.ws.runtime.component.ApplicationMgrImpl$5.run(ApplicationMgrImpl.java:2325)

at com.ibm.ws.security.auth.ContextManagerImpl.runAs(ContextManagerImpl.java:5536)

at com.ibm.ws.security.auth.ContextManagerImpl.runAsSystem(ContextManagerImpl.java:5662)

at com.ibm.ws.security.core.SecurityContext.runAsSystem(SecurityContext.java:255)

at com.ibm.ws.runtime.component.ApplicationMgrImpl.start(ApplicationMgrImpl.java:2330)

at com.ibm.ws.runtime.component.CompositionUnitMgrImpl.start(CompositionUnitMgrImpl.java:436)

at com.ibm.ws.runtime.component.CompositionUnitImpl.start(CompositionUnitImpl.java:123)

at com.ibm.ws.runtime.component.CompositionUnitMgrImpl.start(CompositionUnitMgrImpl.java:379)

at com.ibm.ws.runtime.component.CompositionUnitMgrImpl.access$500(CompositionUnitMgrImpl.java:127)

at com.ibm.ws.runtime.component.CompositionUnitMgrImpl$CUInitializer.run(CompositionUnitMgrImpl.java:985)

at com.ibm.wsspi.runtime.component.WsComponentImpl$_AsynchInitializer.run(WsComponentImpl.java:52

To double confirm on the issue with DB ..try to disable security manually and start Websphere . Login to Admin console and test the DB Datasource connectivity . Share the error with DB team and ask them to fix the issue and test them to connect . Once DB issue solved we should be able to bing up the WebSphere successfully with security enabled and Application also should come up .

Related Posts

Leave a Reply

Your email address will not be published. Required fields are marked *